Go Back   The Supercar Registry > General Discussion > L78 specific Forum


Reply
 
Thread Tools Display Modes
  #51  
Old Yesterday, 04:10 PM
Steve Shauger Steve Shauger is offline
Administrator
 
Join Date: Aug 2000
Location: Long Island, NY
Posts: 2,913
Thanks: 19
Thanked 158 Times in 110 Posts
Default

I just registered the car and was finalizing the maintenance on the car before going for a cruise. I noticed the amp gauge and decided to check the charging voltage 17.8!!!!, not good. Removed the regulator last night and found one set of contacts fused together. I separated the contacts and cleaned and dressed them. Then I noticed a small wire from the contact had burned and opened up, and fixed that as well.


I have another regulator JIC, but plan to install repaired original, which should resolve the over charging issue. I did check the coils and resistors as well and all ok. Should be good to go for another 51 years.
__________________
Steve Shauger
The Supercar Registry
www.yenko.net

Vintage Certification™ , Providing Recognition to Unrestored Muscle Cars. Website:
www.vintagecertification.com
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:05 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.