Go Back   The Supercar Registry > General Discussion > L78 specific Forum


Reply
 
Thread Tools Display Modes
  #11  
Old 10-02-2019, 12:33 AM
TomN TomN is offline
Member
 
Join Date: Jun 2015
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Couple of quick questions if anyone can help. There is a new engine wiring harness on the car but the lead for the oil pressure sensor has a round female end and the pressure sensor itself has a male blade. Pictures I see on line of the sensor for a car with gauges shows a sensor with a male blade like I have.
Also should there be a 45 degree brass fitting between the engine block and the pressure sensor.
Hopefully someone has more knowledge or a better memory than I do.
Thanks for all help !
Reply With Quote
  #12  
Old 10-05-2019, 09:45 PM
tunes's Avatar
tunes tunes is offline
Senior Member
 
Join Date: Jun 2014
Location: SW Missouri
Posts: 141
Thanks: 35
Thanked 33 Times in 23 Posts
Default

The round end for the oil sensor is correct. Oil sensors with the flat terminal like you have are not correct. You should also have the 45 degree brass fitting that the sending unit screws into. I don't have pictures to show you but I'm sure someone here can come up with them.
__________________
Robert
_______________
1969 L78 Chevelle

Last edited by tunes; 10-05-2019 at 09:49 PM.
Reply With Quote
  #13  
Old 10-06-2019, 12:29 AM
TomN TomN is offline
Member
 
Join Date: Jun 2015
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks Robert
Reply With Quote
  #14  
Old 10-11-2019, 11:56 PM
tunes's Avatar
tunes tunes is offline
Senior Member
 
Join Date: Jun 2014
Location: SW Missouri
Posts: 141
Thanks: 35
Thanked 33 Times in 23 Posts
Default

Found this picture, courtesy of Rick Nelson. This is what you should have if your Chevelle has the factory gauge package.
Attached Images
 
__________________
Robert
_______________
1969 L78 Chevelle
Reply With Quote
  #15  
Old 10-16-2019, 01:38 AM
TomN TomN is offline
Member
 
Join Date: Jun 2015
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK. Right now it only has the large round sensor screwed into the block. I can get the other parts, but they might be current reproduction pieces.
But the sensor I have, and the ones I have seen for sell, all have the blade terminal. I will fashion an adapter to connect the wire and sensor.

Right now I have the car in the shop to get the body/metal fixed around the trunk seal.

Thanks again Robert
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:55 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.